1. 29 Aug, 2013 13 commits
  2. 25 Aug, 2013 2 commits
  3. 24 Aug, 2013 1 commit
    • Eric Nelson's avatar
      qt4-embedded: Allow use of Qt Media Player in multi-headed system · 0c905f15
      Eric Nelson authored
      Qt-embedded can be used on multiple screens by using environment variables
      QWS_DISPLAY, QWS_MOUSE_PROTO, et cetera.
      
      The gstreamer element mfw_v4lsink used to accelerate media playback on i.MX
      devices can also be pointed at different displays through the 'device'
      property, but the current acceleration patch doesn't have a mechanism for
      setting the property, and always uses the compiled-in default.
      
      This patch allows userspace startup code to override the default through
      the use of the 'v4lsinkdev' environment variable.
      
      Please refer to the Qt4-embedded documentation for proper usage of the
      QWS_x environment variables and the Freescale Multimedia documentation
      for descriptions of the various gstreamer elements.
      
      A sequence of this for a secondary display might be this:
      
      	export QWS_DISPLAY=linuxfb:/dev/fb2:1
      	export v4lsinkdev=/dev/video19
      	my-qt-app -qws
      Signed-off-by: default avatarEric Nelson <eric.nelson@boundarydevices.com>
      0c905f15
  4. 20 Aug, 2013 4 commits
  5. 15 Aug, 2013 1 commit
  6. 07 Aug, 2013 9 commits
  7. 06 Aug, 2013 1 commit
  8. 05 Aug, 2013 5 commits
  9. 04 Aug, 2013 2 commits
  10. 31 Jul, 2013 2 commits
    • Lauren Post's avatar
      alsa-state: Add default asound.conf for i.MX6 SoCs · b1c55a47
      Lauren Post authored
      Change-Id: I62785bf230635df5deeb6522e4e8236330ea03d2
      Signed-off-by: default avatarLauren Post <lauren.post@freescale.com>
      b1c55a47
    • Otavio Salvador's avatar
      gst-fsl-plugin: Update to 3.0.8 version · bbfe53c9
      Otavio Salvador authored
      This release had many patches merged upstream and thus those are being
      removed. Following patches were merged:
      
       - Link-with-the-Real-Time-Extension-lib.patch
       - fix-missing-sys-types-h.patch
       - v4lsink_back_compatible.patch
       - vss_build_failed.patch
      
      A new runtime dependency for libfslparser has been added. This is need
      to be available at rootfs but no code links to it explicitly so
      gst-fsl-plugin needs to made it explicit.
      
      The file, used in SRC_URI, is from 3.5.7-1.0.0 BSP but its contents
      explicitly say it is a 3.0.8 release so we use the source version to
      avoid supporting different version from different kernel releases.
      
      Change-Id: Id71d436af78dc62f620107d64633bf1ebbdaefef
      Signed-off-by: default avatarOtavio Salvador <otavio@ossystems.com.br>
      bbfe53c9