1. 06 Nov, 2013 6 commits
  2. 04 Nov, 2013 4 commits
  3. 03 Nov, 2013 4 commits
  4. 30 Oct, 2013 3 commits
    • Lucas Dutra Nunes's avatar
      linux-fslc: kernel build now needs GNU bc to work · 06dee2b7
      Lucas Dutra Nunes authored
      The kernel now needs to use GNU bc to be built since version 3.9. The following
      commit message from the kernel explains the reason:
      
      commit 70730bca1331fc50c3caacaea00439de1325bd6e
      Author: H. Peter Anvin <hpa@zytor.com>
      Date:   Thu Feb 14 15:13:55 2013 -0800
      
          kernel: Replace timeconst.pl with a bc script
      
          bc is the standard tool for multi-precision arithmetic.  We switched
          to Perl because akpm reported a hard-to-reproduce build hang, which
          was very odd because affected and unaffected machines were all running
          the same version of GNU bc.
      
          Unfortunately switching to Perl required a really ugly "canning"
          mechanism to support Perl < 5.8 installations lacking the Math::BigInt
          module.
      
          It was recently pointed out to me that some very old versions of GNU
          make had problems with pipes in subshells, which was indeed the
          construct used in the Makefile rules in that version of the patch;
          Perl didn't need it so switching to Perl fixed the problem for
          unrelated reasons.  With the problem (hopefully) root-caused, we can
          switch back to bc and do the arbitrary-precision arithmetic naturally.
      Signed-off-by: 's avatarH. Peter Anvin <hpa@zytor.com>
          Cc: Andrew Morton <akpm@linux-foundation.org>
      Acked-by: 's avatarSam Ravnborg <sam@ravnborg.org>
      Signed-off-by: 's avatarMichal Marek <mmarek@suse.cz>
      
      Change-Id: I09ec3629bf47aa4768bd21b0cfb1ca6fb6f5b18f
      Signed-off-by: 's avatarLucas Dutra Nunes <ldnunes@ossystems.com.br>
      06dee2b7
    • Daiane Angolini's avatar
      gst-fsl-plugin: Add dependency on imx-vpu · 590e1a7b
      Daiane Angolini authored
      libvpu was changed from imx-lib to imx-vpu so
      now gst-fsl-plugins depends on both imx-lib
      and imx-vpu.
      
      imx-lib does provide libipu required by
      gst-fsl-plugin
      
      Change-Id: I623f5aec270f9c0bd19aefdfbf93e4e6222f8fd2
      Signed-off-by: 's avatarDaiane Angolini <daiane.angolini@freescale.com>
      590e1a7b
    • Otavio Salvador's avatar
      u-boot-fslc: Update to revision commit 38322587 · a439201d
      Otavio Salvador authored
      This includes following commit:
      
      commit 3832258715cd19aa3e26ac5f35ef7be230454924
      Author: Otavio Salvador <otavio@ossystems.com.br>
      Date:   Tue Oct 29 15:00:24 2013 -0200
      
          mx6sabre{auto,sd}: Change FDT loading address to avoid overlaping
      
          The new FSL 3.10.9_1.0.0-alpha kernel requires more memory space and
          with the previous loading address we had ovelap; change it for the
          same address used in 2013.04-3.10.9_1.0.0-alpha U-Boot.
      Tested-by: 's avatarDaiane Angolini <daiane.angolini@freescale.com>
      Signed-off-by: 's avatarOtavio Salvador <otavio@ossystems.com.br>
      
      Change-Id: I7bf08f962b7956ba6f4c645a1d3ed0188eb8ac0d
      Signed-off-by: 's avatarOtavio Salvador <otavio@ossystems.com.br>
      a439201d
  5. 28 Oct, 2013 4 commits
  6. 18 Oct, 2013 6 commits
    • Daiane Angolini's avatar
      imx-test: Add dependency on imx-vpu · ad7d3b3e
      Daiane Angolini authored
      Change-Id: Id3dce7c7531acb790e289438adfe08b5b9bcf87c
      Signed-off-by: 's avatarDaiane Angolini <daiane.angolini@freescale.com>
      ad7d3b3e
    • Daiane Angolini's avatar
      imx-vpu: Add imx-vpu version 11.09.02 · 5ee5f871
      Daiane Angolini authored
      This package wraps lib-vpu with proper
      licensing.
      
      Change-Id: I21da011672eb2ce7c000abd4f5ed10baec58d9ba
      Signed-off-by: 's avatarDaiane Angolini <daiane.angolini@freescale.com>
      5ee5f871
    • Daiane Angolini's avatar
      imx-lib: Move from 11.09.01 to 11.09.02 · 8ece0352
      Daiane Angolini authored
      The lib-vpu must be remove from imx-lib package due to
      a license conflict.
      
      Beside that a list of patches was included over 11.09.01:
      
      * ENGR00277379 yocto: Makefile changes to build on Yocto
      * ENGR00272020 Add EULA.txt to VPU lib directory
      * ENGR00215182 HDMI CEC:Add Makefile of hdmi-cec lib
      * ENGR00234665 Enable pxp library building
      * ENGR00230334: Fix for GCC 4.6 toolchain and build warnings
      * ENGR00221837-2 ipu lib: only build for i.MX5 platform
      * ENGR00179726-2 Add VDOA V4L support to VPU unit test
      * ENGR00177165: Fix build error of missing videodev.h
      * ENGR00174611: Configured ePxP lib for MX6
      * ENGR00170744 IPU lib:Control interface supports allocating pmem buf
      * ENGR00170632 IPU lib:Allocate pmem buf for rotation buf
      * ENGR00170455 IPU lib:Change head file for flash
      
      Change-Id: I034f22535d78edfce08519eead0310b2a8b4e4a0
      Signed-off-by: 's avatarDaiane Angolini <daiane.angolini@freescale.com>
      8ece0352
    • Otavio Salvador's avatar
      linux-fslc: Update to 3.12-rc5 based release · 550a63b8
      Otavio Salvador authored
      This updates to 3.12-rc5 kernel. Following patches are still pending:
      
      83cc074 iio: mxs-lradc: Fix the order of resources removal
      bc59b31 iio: mxs-lradc: Add MODULE_ALIAS
      569cd56 ARM: mxs-lradc: Simplify mxs_lradc_trigger_init error handle
      0e35b56 ARM: dts: imx28-evk: Enable touchscreen support
      
      Change-Id: I335d7ee2016e72b694cf66d0bdb2f86d92d5e374
      Signed-off-by: 's avatarOtavio Salvador <otavio@ossystems.com.br>
      550a63b8
    • Otavio Salvador's avatar
      u-boot-fslc: Update to 2013.10 based release · 0b0dfeb4
      Otavio Salvador authored
      This updates the U-Boot fork to a 2013.10 based release and include
      following changes on top of that:
      
      4b2e99f mx6sabresd: Use mmcblk0 for CONFIG_MMCROOT
      60fe20e mx28evk: Extend environment to easy write of NAND system
      e2f0dee mx28evk: Add 'nandboot' environment command
      319cafc mx28evk: Use 512k for fdt partition to align it
      e92e0d3 imx_watchdog: do not soft-reset while watchdog init
      
      Change-Id: Ib875751bdc66325fb8237c553529a2462bd76176
      Signed-off-by: 's avatarOtavio Salvador <otavio@ossystems.com.br>
      0b0dfeb4
    • Khem Raj's avatar
      machines: Add PREFERRED_PROVIDER for virtual/bootloader · 93b3d7dd
      Khem Raj authored
      virtual/bootloader is a commonly used target. This patch
      adds it for meta-fsl-arm machines.
      
      Other BSP layers have this provider and when using a mutli-machine
      distro setup bitbake virtual/bootloader
      builds a wrong u-boot for fsl machines
      Signed-off-by: 's avatarKhem Raj <raj.khem@gmail.com>
      93b3d7dd
  7. 16 Oct, 2013 1 commit
  8. 14 Oct, 2013 2 commits
  9. 09 Oct, 2013 1 commit
  10. 08 Oct, 2013 6 commits
  11. 05 Oct, 2013 1 commit
    • Eric BENARD's avatar
      imx-base: provide right package for amd-gpu-bin if x11 is disabled · 00f0cf37
      Eric BENARD authored
      so that users don't have to customize it outside,
      else we get very stranges errors like :
      ERROR: Multiple versions of mesa are due to be built
      (/scratch/openembedded-core/meta/recipes-graphics/mesa/mesa_git.bb
      /scratch/openembedded-core/meta/recipes-graphics/mesa/mesa_9.1.6.bb).
      Only one version of a given PN should be built in any given build.
      You likely need to set PREFERRED_VERSION_mesa to select the correct
      version or don't depend on multiple versions.
      Signed-off-by: 's avatarEric Bénard <eric@eukrea.com>
      00f0cf37
  12. 01 Oct, 2013 2 commits