Commit 6d30a1f5 authored by Martin Jansa's avatar Martin Jansa

connman: remove if_alg.h test from configure

* we're not building alg-test and if_alg.h needs newer linux-libc-headers than many distributions prefer now
Signed-off-by: default avatarMartin Jansa <Martin.Jansa@gmail.com>
parent 059369b2
......@@ -25,7 +25,9 @@ SRC_URI = "\
SRC_URI[md5sum] = "59b4cfd9fa4f736f7a2d88ee0c758fe9"
SRC_URI[sha256sum] = "bf58fa72454bb63033da8f847a4709dbdfe64c000056a93a7504240cb31c1321"
# alg-test doesn't build, so disable that
# alg-test doesn't build, so disable that and test for if_alg.h as this header is only in 2.6.39
do_configure_prepend() {
sed -i 's:tools/alg-test ::g' Makefile.am
sed -i 's:AC_CHECK_HEADERS(linux/if_alg.h, dummy=yes,::g;
s:AC_MSG_ERROR(User-space algorithm header files are required))::g' configure.ac
}
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment