Commit db1107d7 authored by Martin Jansa's avatar Martin Jansa Committed by Koen Kooi

evas: add evas-loader-svg back to RRECOMMENDS

* it doesn't look like whole Gtk+ anymore, but still needs gdk-pixbuf,
  libcairo2 etc.

  Package: evas-loader-svg
  Depends: libxcb1 (>= 1.7), libxrender1 (>= 0.9.6), libpixman-1-0 (>= 0.22.2), libxml2 (>= 2.7.8), libz1 (>= 1.2.5), librsvg-2-2 (>= 2.32.1), libfreetype6 (>= 2.4.6), eina (>= 1.0.999+svnr62850), libgcrypt11 (>= 1.4.6), libpng12-0 (>= 1.2.46), libffi5 (>= 3.0.9), gdk-pixbuf (>= 2.22.1), libcairo2 (>= 1.10.2), libstdc++6 (>= 4.6.1+svnr175454), libglib-2.0-0 (>= 2.29.3+gitr1+d97cbc6731deab137770bc0fe9c69b06f689f5b4), libxau6 (>= 1.0.6), libjpeg8 (>= 8c), libx11-6 (>= 1.4.3), evas (>= 1.0.999+svnr62850), libfribidi0 (>= 0.19.2), libc6 (>= 2.13), pango (>= 1.28.3), libgpg-error0 (>= 1.10), libgnutls26 (>= 2.12.5), libeet1 (>= 1.4.999+svnr62850), libtasn1-3 (>= 2.9), libexpat1 (>= 2.0.1), libxdmcp6 (>= 1.1.0), libfontconfig1 (>= 2.8.0)

  Package: librsvg-2-2
  Depends: libx11-6 (>= 1.4.3), libpixman-1-0 (>= 0.22.2), libxcb1 (>= 1.7), libc6 (>= 2.13), libxrender1 (>= 0.9.6), libffi5 (>= 3.0.9), libxml2 (>= 2.7.8), libz1 (>= 1.2.5), libfreetype6 (>= 2.4.6), gdk-pixbuf (>= 2.22.1), libpng12-0 (>= 1.2.46), libcairo2 (>= 1.10.2), libstdc++6 (>= 4.6.1+svnr175454), libglib-2.0-0 (>= 2.29.3+gitr1+d97cbc6731deab137770bc0fe9c69b06f689f5b4), libxau6 (>= 1.0.6), libexpat1 (>= 2.0.1), pango (>= 1.28.3), libxdmcp6 (>= 1.1.0), libfontconfig1 (>= 2.8.0)

* but otherwise e-wm keeps complaining about missing svg support
  <<<< Enlightenment Error >>>>
  Enlightenment found Evas can't load SVG files. Check Evas has SVG loader
  support.

* we can also RRECOMMEND it only from e-wm, so people using only evas
  without e-wm won't get it by default
Signed-off-by: default avatarMartin Jansa <Martin.Jansa@gmail.com>
parent 6c4ade87
......@@ -44,6 +44,7 @@ RRECOMMENDS_${PN} = " \
evas-loader-jpeg \
evas-loader-eet \
evas-loader-gif \
evas-loader-svg \
"
# Some upgrade path tweaking
......@@ -74,11 +75,6 @@ RREPLACES_evas-engine-buffer = "liblibevas-ver-pre-svn-00-engine-buffer libevas-
RREPLACES_evas-engine-xrender-x11 = "liblibevas-ver-pre-svn-00-engine-xrender-x11 libevas-ver-pre-svn-00-engine-xrender-x11 "
RREPLACES_evas-engine-software-x11 = "liblibevas-ver-pre-svn-00-engine-software-x11 libevas-ver-pre-svn-00-engine-software-x11 "
# disabling this, since (due to OE bugs) it drags in whole Gtk+
#RRECOMMENDS_${PN} += " \
# libevas-loader-svg \
#"
EVAS_CPU_TWEAKS = ""
# Disabled for now, see http://thread.gmane.org/gmane.comp.window-managers.enlightenment.devel/25194
EVAS_CPU_TWEAKS_armv7a = "--disable-cpu-neon"
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment