Commit 43ece255 authored by Dmitry Eremin-Solenikov's avatar Dmitry Eremin-Solenikov Committed by Martin Jansa

meta-oe: override SECURITY_CFLAGS for a set of recipes

Some of recipes produce errors if the distro has enabled usage of
security_flags.inc file. Fix those errors (and QA warnings) by providing
an additional include file that is require'd from conf/layer.conf.
Signed-off-by: 's avatarDmitry Eremin-Solenikov <dmitry_eremin@mentor.com>
Signed-off-by: 's avatarMartin Jansa <Martin.Jansa@gmail.com>
parent 4429a325
# Build errors with the pie options enabled
SECURITY_CFLAGS_pn-lvm2 = "${SECURITY_NO_PIE_CFLAGS}"
SECURITY_CFLAGS_pn-rrdtool = "${SECURITY_NO_PIE_CFLAGS}"
# This has text reloc errors with the pie options enabled
SECURITY_CFLAGS_pn-mozjs = "${SECURITY_NO_PIE_CFLAGS}"
SECURITY_CFLAGS_pn-openldap = "${SECURITY_NO_PIE_CFLAGS}"
......@@ -44,3 +44,6 @@ SIGGEN_EXCLUDE_SAFE_RECIPE_DEPS += " \
"
FREESMARTPHONE_GIT = "git://git.freesmartphone.org"
# Override security flags
require conf/distro/include/meta_oe_security_flags.inc
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment